const regex = /(?J)^.*something1,(?:,|(?<src_username>[^,\\]+),|(?<src_domain>[^,\\]+)\\(?<src_username>[^,\\]+),)(?:,|(?<dst_user>[^\\,]+),|(?<dst_domain>[^,\\]+)\\(?<dst_username>[^,\\]*),)something2.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?J)^.*something1,(?:,|(?<src_username>[^,\\\\]+),|(?<src_domain>[^,\\\\]+)\\\\(?<src_username>[^,\\\\]+),)(?:,|(?<dst_user>[^\\\\,]+),|(?<dst_domain>[^,\\\\]+)\\\\(?<dst_username>[^,\\\\]*),)something2.*', 'gm')
const str = `something1,,,something2
something1,,dstuser,something2
something1,,dstdomain\\dstuser,something2
something1,srcdomain\\srcuser,,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstuser,something2
something1,srcuser,,something2
something1,srcdomain\\srcuser,dstuser,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}