using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)";
string input = @"<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}