package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)`)
var str = `<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}