const regex = /(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)section:(.*?)subsection:([0-9]+)\\s+((?:xy:[0-9]*_[^\\n]+\\r?\\n)+)', 'g')
const str = `<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}