import re
regex = re.compile(r"(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)")
test_str = ("<who know's whats here>\n"
"section:NumberOfSurvivorsPerVault\n"
"subsection:1958\n"
"xy:1_1034\n"
"xy:2_2334\n"
"...\n"
"<some other line>\n\n"
"<who know's whats here>\n"
"section:NumberOfSurvivorsPerVault\n"
"subsection:1958\n"
"xy:1_1034\n"
"xy:2_2334\n"
"...\n"
"<some other line>\n\n"
"<who know's whats here>\n"
"section:NumberOfSurvivorsPerVault\n"
"subsection:1958\n"
"xy:1_1034\n"
"xy:2_2334\n"
"...\n"
"<some other line>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")