$re = '/(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)/';
$str = '<who know\'s whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know\'s whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know\'s whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);