import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)section:(.*?)subsection:([0-9]+)\\s+((?:xy:[0-9]*_[^\\n]+\\r?\\n)+)";
final String string = "<who know's whats here>\n"
+ "section:NumberOfSurvivorsPerVault\n"
+ "subsection:1958\n"
+ "xy:1_1034\n"
+ "xy:2_2334\n"
+ "...\n"
+ "<some other line>\n\n"
+ "<who know's whats here>\n"
+ "section:NumberOfSurvivorsPerVault\n"
+ "subsection:1958\n"
+ "xy:1_1034\n"
+ "xy:2_2334\n"
+ "...\n"
+ "<some other line>\n\n"
+ "<who know's whats here>\n"
+ "section:NumberOfSurvivorsPerVault\n"
+ "subsection:1958\n"
+ "xy:1_1034\n"
+ "xy:2_2334\n"
+ "...\n"
+ "<some other line>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}