# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*\KREPLACE_ME(?=[^>]*>)/REPLACED/gm;t' <<< "<div class=\"REPLACE_ME\" id=\"my_id\">this REPLACE_ME cannot be replaced</div>
<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>
<div REPLACE_ME=\"my_attribute\">this REPLACE_ME cannot be replaced</div>"