import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*\\KREPLACE_ME(?=[^>]*>)";
final String string = "<div class=\"REPLACE_ME\" id=\"my_id\">this REPLACE_ME cannot be replaced</div>\n"
+ "<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>\n"
+ "<div REPLACE_ME=\"my_attribute\">this REPLACE_ME cannot be replaced</div>";
final String subst = "REPLACED";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}