$re = '/<[^>]*\KREPLACE_ME(?=[^>]*>)/m';
$str = '<div class="REPLACE_ME" id="my_id">this REPLACE_ME cannot be replaced</div>
<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>
<div REPLACE_ME="my_attribute">this REPLACE_ME cannot be replaced</div>';
$subst = "REPLACED";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;