const regex = /<[^>]*\KREPLACE_ME(?=[^>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*\\KREPLACE_ME(?=[^>]*>)', 'gm')
const str = `<div class="REPLACE_ME" id="my_id">this REPLACE_ME cannot be replaced</div>
<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>
<div REPLACE_ME="my_attribute">this REPLACE_ME cannot be replaced</div>`;
const subst = `REPLACED`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);