using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*\KREPLACE_ME(?=[^>]*>)";
string substitution = @"REPLACED";
string input = @"<div class=""REPLACE_ME"" id=""my_id"">this REPLACE_ME cannot be replaced</div>
<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>
<div REPLACE_ME=""my_attribute"">this REPLACE_ME cannot be replaced</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}