import re
regex = re.compile(r"<[^>]*\KREPLACE_ME(?=[^>]*>)", flags=re.MULTILINE)
test_str = ("<div class=\"REPLACE_ME\" id=\"my_id\">this REPLACE_ME cannot be replaced</div>\n"
"<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>\n"
"<div REPLACE_ME=\"my_attribute\">this REPLACE_ME cannot be replaced</div>")
subst = "REPLACED"
result = regex.sub(subst, test_str)
if result:
print(result)