package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s|:|\{|\})`)
var str = `{
: 12,
: 24,
: 36,
: 44,
: 138,
: 195,
: 127,
: 91,
: 52,
: 45,
: 21,
: 15
}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}