# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s|:|\{|\})"
test_str = ("{\n"
" : 12,\n"
" : 24,\n"
" : 36,\n"
" : 44,\n"
" : 138,\n"
" : 195,\n"
" : 127,\n"
" : 91,\n"
" : 52,\n"
" : 45,\n"
" : 21,\n"
" : 15\n"
" }")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.