re = /(?:\s|:|\{|\})/m
str = '{
: 12,
: 24,
: 36,
: 44,
: 138,
: 195,
: 127,
: 91,
: 52,
: 45,
: 21,
: 15
}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result