use strict;
my $str = '{
: 12,
: 24,
: 36,
: 44,
: 138,
: 195,
: 127,
: 91,
: 52,
: 45,
: 21,
: 15
}';
my $regex = qr/(?:\s|:|\{|\})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";