// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\s|:|\{|\})").unwrap();
let string = "{
: 12,
: 24,
: 36,
: 44,
: 138,
: 195,
: 127,
: 91,
: 52,
: 45,
: 21,
: 15
}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}