$re = '/(?:\s|:|\{|\})/m';
$str = '{
: 12,
: 24,
: 36,
: 44,
: 138,
: 195,
: 127,
: 91,
: 52,
: 45,
: 21,
: 15
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;