#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])"
Local $sString = "oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)