import Foundation
let pattern = #"(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)