using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])";
string substitution = @"";
string input = @"oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}