const regex = /(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[|(?<!^)\\G),? *(\\w+)(?=[^\\[\\]]*\\])', 'gm')
const str = `oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);