use strict;
my $str = 'oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]';
my $regex = qr/(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";