re = /(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])/m
str = 'oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result