$re = '/(?:\[|(?<!^)\G),? *(\w+)(?=[^\[\]]*\])/m';
$str = 'oneWord [first, second, third] hghg] (jhjh, kjhk] [bar,foo,foobar]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;