using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]+@[\w]{2,}+\.[\w]{2,}";
string input = @"an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}