re = /[\w]+@[\w]{2,}+\.[\w]{2,}/
str = 'an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end