// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w]+@[\w]{2,}+\.[\w]{2,}").unwrap();
let string = "an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}