package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w]+@[\w]{2,}+\.[\w]{2,}`)
var str = `an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}