import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w]+@[\\w]{2,}+\\.[\\w]{2,}";
final String string = "an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}