use strict;
my $str = 'an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru ';
my $regex = qr/[\w]+@[\w]{2,}+\.[\w]{2,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}