$re = '/[\w]+@[\w]{2,}+\.[\w]{2,}/';
$str = 'an online regex tester for navigatex@ya.ru javascript, php, pcre and python. smittnchelny@mail.ru elcin8@ya.ru eld_saa@gmail.com sdlf/fh@ghd.re 1@ddfsf.ru ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);