using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)\s+(?=\d)";
string substitution = @"$1";
string input = @"The store is 5 6 7 8";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}