import re
regex = re.compile(r"(\d)\s+(?=\d)")
test_str = "The store is 5 6 7 8"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)