const regex = /(\d)\s+(?=\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)\\s+(?=\\d)', 'g')
const str = `The store is 5 6 7 8`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);