using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^+>]*)[^<]*(<a [^>]*(href=""([^>^\""]*)"")[^>]*>)([^<]+)(<\/a>)";
string input = @"This is <a target=""_blank"" href=""www.google.com?Test=t+1"">test</a> a rabbit
My second sentence <a href=""www.msn.co.uk"">test 2</a> is here dfdfdf.
Third sentence <a href=""www.yahoo.co.uk"" target=""_blank"">test 3</a> a rabbitdddd";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}