import re
regex = re.compile(r"([^+>]*)[^<]*(<a [^>]*(href=\"([^>^\"]*)\")[^>]*>)([^<]+)(<\/a>)", flags=re.IGNORECASE)
test_str = ("This is <a target=\"_blank\" href=\"www.google.com?Test=t+1\">test</a> a rabbit\n"
"My second sentence <a href=\"www.msn.co.uk\">test 2</a> is here dfdfdf.\n"
"Third sentence <a href=\"www.yahoo.co.uk\" target=\"_blank\">test 3</a> a rabbitdddd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")