$re = '/([^+>]*)[^<]*(<a [^>]*(href="([^>^\"]*)")[^>]*>)([^<]+)(<\/a>)/i';
$str = 'This is <a target="_blank" href="www.google.com?Test=t+1">test</a> a rabbit
My second sentence <a href="www.msn.co.uk">test 2</a> is here dfdfdf.
Third sentence <a href="www.yahoo.co.uk" target="_blank">test 3</a> a rabbitdddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);