use strict;
my $str = 'This is <a target="_blank" href="www.google.com?Test=t+1">test</a> a rabbit
My second sentence <a href="www.msn.co.uk">test 2</a> is here dfdfdf.
Third sentence <a href="www.yahoo.co.uk" target="_blank">test 3</a> a rabbitdddd';
my $regex = qr/([^+>]*)[^<]*(<a [^>]*(href="([^>^\"]*)")[^>]*>)([^<]+)(<\/a>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}