import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^+>]*)[^<]*(<a [^>]*(href=\"([^>^\\\"]*)\")[^>]*>)([^<]+)(<\\/a>)";
final String string = "This is <a target=\"_blank\" href=\"www.google.com?Test=t+1\">test</a> a rabbit\n"
+ "My second sentence <a href=\"www.msn.co.uk\">test 2</a> is here dfdfdf.\n"
+ "Third sentence <a href=\"www.yahoo.co.uk\" target=\"_blank\">test 3</a> a rabbitdddd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}