#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b\w+\b\W*){,4}[A-Z]{3,}\W*(\b\w+\b\W*){,4}"
Local $sString = "Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW." & @CRLF & _
"I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?" & @CRLF & _
"Thank you a lot for your SUPPORT and for all the time you have spent. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")