use strict;
my $str = 'Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW.
I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?
Thank you a lot for your SUPPORT and for all the time you have spent. ';
my $regex = qr/(\b\w+\b\W*){,4}[A-Z]{3,}\W*(\b\w+\b\W*){,4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}