// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b\w+\b\W*){,4}[A-Z]{3,}\W*(\b\w+\b\W*){,4}").unwrap();
let string = "Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW.
I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?
Thank you a lot for your SUPPORT and for all the time you have spent. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}