using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+\b\W*){,4}[A-Z]{3,}\W*(\b\w+\b\W*){,4}";
string input = @"Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW.
I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?
Thank you a lot for your SUPPORT and for all the time you have spent. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}