import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\w+\\b\\W*)\\{,4\\}[A-Z]{3,}\\W*(\\b\\w+\\b\\W*)\\{,4\\}";
final String string = "Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW.\n"
+ "I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?\n"
+ "Thank you a lot for your SUPPORT and for all the time you have spent. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}