# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b\w+\b\W*){,4}[A-Z]{3,}\W*(\b\w+\b\W*){,4}"
test_str = ("Lorem IPSUM is simply DUMMY text of the printing and typesetting INDUSTRY Lorem AB is simply DUMMY text of the printing and typesetting INDUSTRY Lorem is simply text of the printing and typesetting UW.\n"
"I know nothing at all about REGEX but I want to learn. Could you Help ME to learn? Please?\n"
"Thank you a lot for your SUPPORT and for all the time you have spent. ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.