#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})"
Local $sString = "INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου" & @CRLF & _
"([A-Za-z]{3}|[Α-Ωα-ω]{3})\d{3,4}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")