// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})").unwrap();
let string = "INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου
([A-Za-z]{3}|[Α-Ωα-ω]{3})\\d{3,4}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}