import Foundation
let pattern = #"([A-Za-zΑ-Ωα-ω]{2,3}\d{1,4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
INTERLIFE-ΠροασφαλιστικόςΈλεγχος(ΧRΦ8985)-Λήξησυνδέσμου
([A-Za-z]{3}|[Α-Ωα-ω]{3})\d{3,4}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}